Welcome Guest, Not a member yet? Create Account  


(This post was last modified: 07-19-2019, 02:22 AM by Bushman. Edit Reason: solved it )

Good evening guys

Please would you see if you can help.....?

It has been 5 years since I did any earthworks takeoffs. Previously used 12D (Australian product) and now hoping to get back into it via Kubla.

I have an opportunity to start a 'side business doing takeoffs but first have to prove to the client I am proficient.

The estimator sent me a 'dummy project' and it has me stumped.

The files sent are in DWG/DXF and I am not getting the info I need.

Looking at the help files it seems you guys are using external CAD software to weed the file of unwanted info and then importing it into Kubla.

This is a very simple job but I am struggling with weeding out the info and getting it imported into Kubla.

Please..... please...... help.

These are the files I was given.
What 3rd party CAD software are you guys using to extract 'existing' and 'design'?


The CAD file has the usual 2D info and the 3D info. Viewing it in 3D you can see the info with '0' Z value as well as the info which has 'Z' values. The info with 'Z' values is shown with existing and design. But I have no idea how to seperate the two in Kubla.

Kubla gives options for 'break lines' 'contours' & 'boundaries' but not for the point vertices (existing spot levels).

I know am new to Kubla and the answer is probably right in front of me........... apologies for that....

Attached Files Image(s)

(This post was last modified: 07-19-2019, 02:21 AM by Bushman.)

Just goes to show..... the answer is in there somewhere.

Went to bed last night pretty defeated.

This morning I whatched the youtube video on 'Working with CAD data' for the 4'th time. Went into DraftSight and made sure all the data is indeed there.
Went back into Kubla and found the magic button.

Kubla kept telling me there are no spot levels in the imported CAD file. I know they are there so either the CAD file perhaps had the spot files in some other format I am not aware of, or Kuble just did not have a way of recognising them.

Turns out the magic button was right there and it solved it all. I just needed to tell Kubla how the spot levels were defined in the CAD file.

Onward and Forward I go......

Attached Files Image(s)

(This post was last modified: 07-19-2019, 05:06 PM by Ted Woods.)

Sorry to hear you have run into so many problems on your first attempt, you are correct this project should be fairly trivial for the program. 
Suitability of CAD Data for Import :
Kubla Cubed imports CAD data using layers (you can copy and paste to if you have a CAD program).  The problem I see with the CAD data is that it there are just so many layers with different naming conventions and formatting it is very confusing.  For purposes of Volumetric surface comparison it is worth being very clear with the naming (e.g Existing_Conts_MJR etc…)
The existing points seem to be in :

The points as you noticed are not contained in ‘point’ entities but ‘blocks’ so you have to set the point importer to detect blocks.
The contour lines I had no problem with apart from finding which elevation information was in which layer.  I actually found that there are existing contours  in layers :
which can be used to improve the definition of existing.  The proposed contours where in
I had no problems with any of these, could your problem have related to not turning on\off the layers which contained the relevant data ?.  I could find no representation of the proposed “match line” indicated on the site plan, it was in there but in order to be imported into Kubla Cubed as a Ground Level Boundary Outline, the CAD entity would need to be a closed Polyline or a closed 3D polyline and currently it is a number of loosely connected line segments.

Users browsing this thread:
1 Guest(s)